Sie sind nicht angemeldet.

1

Dienstag, 16. April 2019, 16:55

Scannen in Hyper-V Umgebung und Terminalserver (TWAIN Treiber nicht erkannt - gelöst)

Wir betreiben seit ca. 4 Wochen MedicalOffice und hatten mit zahlreichen Problemen zu kämpfen, die mit unserer Infrastruktur zu tun hatten.
Ein großes Problem stellte unser TWAIN Scanner von Fujitsu dar.


Die gute Nachricht vorweg - das Problem konnten wir aus eigener Kraft lösen.
Die schlechte Nachricht ist, dass werder unser Solution-Provider noch Indamed etwas zur Lösung beitragen konnten - Hinweise der Hotlines waren allesamt falsch.

Zur Situation:
Wir haben eine auf Hyper-V basierende virtuelle Umgebung (WINDOWS Server 2016) auf der wir einen Terminalserver betreiben, über den die Arbeitsplätze auf den MO-Server zugreifen.
Das Anschließen von USB Geräten funktioniert in einer virtuellen Umgebung nur mit zusätzlicher Hardware (z.B. von SILEX) und ist grundsätzlich überhaupt kein Problem.
Eine Installation der Scannersoftware + Treiber ist ebenso trivial und erfordert wenig Fachkenntnis.


Das Problem entsteht bei der Verwendung von Medical Office: Startet man einen Scan, öffnet MO im Hintergrund das Programm modokuablage.exe
Dieses Programm findet leider keinen der installierten TWAIN Treiber.

Seitens Indamed und Solution Provider teilte man uns mit, dass wir den Treiber aktualisieren sollten, bzw. das ganze so nicht zum Laufen zu bringen ist bzw. dass wir einen neuen Scanner kaufen sollten...

Die Lösung ist einfach wie auch komplex gewesen: Zunächst ist festzuhalten, dass das Programm modokuablage.exe NICHT TERMINALSERVER-geeignet ist!!!!
Glücklicherweise lässt sich die exe-Datei terminalserver-gerecht machen: Die ausführliche Anleitung findet man hier


https://deref-1und1.de/mail/client/8Nd_Av-VoPU/dereferrer/?redirectUrl=https%3A%2F%2Fwww.remkoweijnen.nl%2Fblog%2F2012%2F12%2F04%2Ffile-not-found-error-when-scanning-using-twain-redirection-in-citrix-xenapp%2F



Ich würde erwarten, dass soetwas nicht durch den Anwender gelöst werden muss.


In der Hoffnung, dass dies auch anderen hilft
Dr. Walbröl-Schley

2

Mittwoch, 17. April 2019, 07:31

Hallo Dr. Walbröl-Schley,

vielen Dank für Ihren Hinweis, ich habe diesbezüglich einen Bug erfasst. Wir werden die modokuablage.exe ändern, so dass kein Eingreifen eines Anwenders mehr erforderlich sein wird.

Gruß B.Kowalewski

3

Dienstag, 10. März 2020, 09:43

Hallo,
erstmal Danke an Dr. Walbröl-Schley für die Offenlegung des Problems und auch den Lösungsansatz.
Da bei uns aktuell auch die Umstellung auf einen neuen Server ansteht
und da auch immer wieder über eine Terminalserver-Lösung nachgedacht
wird, kam ich zu diesem Beitrag.
Hallo Dr. Walbröl-Schley,

vielen Dank für Ihren Hinweis, ich habe diesbezüglich einen Bug erfasst. Wir werden die modokuablage.exe ändern, so dass kein Eingreifen eines Anwenders mehr erforderlich sein wird.

Gruß B.Kowalewski

Wurde dieser Bug bereits behoben - also ist modokuablage.exe inzwischen 100% Terminalserverfäig?
Wie sieht es sonst mit Medical Office in einer Terminalserverlösung aus? Klappt das ganz gut?
LG,
JanV